Закажите бесплатный расчет стоимости вашей задачи по 1С!
Перезвоним за 10 минут!

Инструкция по загрузке из Excel в 1C для программиста

Нужно загрузить большой объем данных из Экселя в 1С? Настроить постоянную загрузку накладных и товаров? Обратитесь к нам! Оставьте заявку в форме выше или позвоните нам по телефону +7 499 499 76 06.

Несомненно, одним из самых распространенных способов массового занесения информации в информационную систему является загрузка информации в 1С 8.3 из Excel. Ниже я рассмотрю пошаговое создание обработки загрузки данных, и дам ссылку на скачивание её.

Данная инструкция написана для программистов, для пользователей 1С скорее подойдут следующие статьи:

Самые популярные данные, которые требуются для загрузки в 1С из Excel:

  • номенклатура и её штрих-коды, в том числе с картинками;
  • накладные от поставщика;
  • прайс листы от контрагентов;
  • начальные остатки по складам или бухгалтерскому учету.

MS Excel — программа для работы с электронными таблицами, созданная компанией  Microsoft. Она предоставляет возможности экономико-статистических расчетов, графические инструменты и язык макропрограммирования VBA. Excel является одним из наиболее популярных приложений в мире.

Из Excel в 1С 8.3

Обработку мы будем делать универсальную, подобно той, что мы делали для загрузки файлов csv в 1С.

1. Создание обработки загрузки и её формы

Интерфейс программы

Тут мы особо ничего не будем придумывать, сделаем поле ввода для выбора файла на диске, кнопку «Прочитать» для чтения файла и заполнения табличной части.

2 Обработчик выбора файла

Тут всё сделаем как в загрузке из CSV:

При нажатии на выбор файла необходимо отображать диалог выбора файла в ОС. Сделать это очень просто. Необходимо на обработчик “НачалоВыбора” в поле ввода файла указать следующий код:

ДиалогВыбора = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Открытие);
ДиалогВыбора.Заголовок = “Выберите файл”;

Если ДиалогВыбора.Выбрать() Тогда
ИмяФайла = ДиалогВыбора.ПолноеИмяФайла;
КонецЕсли;

3 Обработка данных из Excel и загрузка в 1С 8.3

Для начала мы очищаем информацию в таблице, находим файл на диске, подключаемся к Excel через COM-объект и проводим все технические настройки:

//очищаем таблицу и удаляем колонки
Таблица.Очистить();
Таблица.Колонки.Очистить();
ЭлементыФормы.Таблица.Колонки.Очистить();

Получите 267 видеоуроков по 1С бесплатно:

//подключаемся к эксель
Попытка
Excel = Новый COMОбъект("Excel.Application");
Excel.WorkBooks.Open(ИмяФайла);
Состояние("Обработка файла Microsoft Excel...");
Исключение
Сообщить("Ошибка при открытии файла с помощью Excel! Загрузка не будет произведена!");
Сообщить(ОписаниеОшибки());
Возврат;
КонецПопытки;

Попытка
//Открываем необходимый лист
Excel.Sheets(1).Select(); // лист 1, по умолчанию
Исключение
//Закрываем Excel
Excel.ActiveWorkbook.Close();
Excel = 0;
Сообщить("Файл "+Строка(ИмяФайла)+" не соответствует необходимому формату! Первый лист не найден!");
ОтменитьТранзакцию();
Возврат;
КонецПопытки;

//Получим количество строк и колонок.
//В разных версиях Excel получаются по-разному, поэтому сначала определим версию Excel
Версия = Лев(Excel.Version,Найти(Excel.Version,".")-1);
Если Версия = "8" тогда
ФайлСтрок = Excel.Cells.CurrentRegion.Rows.Count;
ФайлКолонок = Макс(Excel.Cells.CurrentRegion.Columns.Count, 13);
Иначе
ФайлСтрок = Excel.Cells(1,1).SpecialCells(11).Row;
ФайлКолонок = Excel.Cells(1,1).SpecialCells(11).Column;
Конецесли;

После того как мы получили все данные из файла, мы считываем 1 строку файла и генерируем колонки на форме с наименованиями из файла:

//считываем первую строку и генерируем колонки

Сч = 1;
Пока ЗначениеЗаполнено(Excel.Cells(1, Сч).Text) Цикл
ИмяКолонки = Excel.Cells(1, Сч).Text;
ИмяБезПробелов = СтрЗаменить(ИмяКолонки," ",""); // убираем из имени колонок пробелы
Таблица.Колонки.Добавить(ИмяБезПробелов,,ИмяКолонки);
НоваяКолонка = ЭлементыФормы.Таблица.Колонки.Добавить(ИмяБезПробелов, ИмяКолонки);
НоваяКолонка.Данные = ИмяБезПробелов;
Сч = Сч + 1;
КонецЦикла;

После формирования колонок, считываем тело файла эксель и построчно заносим данные в табличное поле:

Для НС = 2 по ФайлСтрок Цикл // НС указываем с какой строки начинать обработку

Состояние("Файл "+Строка(ИмяФайла)+": Обрабатывается первый лист "+Строка(Формат(?(ФайлСтрок=0,0,((100*НС)/ФайлСтрок)),"ЧЦ=3; ЧДЦ=0"))+" %");

ОбработкаПрерыванияПользователя(); //указав данный оператор, цикл можно прервать в любой момент нажатие ctrl+break

НоваяСтрока = Таблица.Добавить();

Для НомерКолонки = 1 по Таблица.Колонки.Количество() Цикл
//заполняем строку значениями
ТекущееЗначение = Excel.Cells(НС, НомерКолонки).Text;
ИмяКолонки = Таблица.Колонки[НомерКолонки-1].Имя;
НоваяСтрока[ИмяКолонки] = ТекущееЗначение;
КонецЦикла;

КонецЦикла;

В результате мы получаем загруженные данные из excel c такими же колонками:

Результат загрузки

Не забудьте закрыть Эксель в 1С после выполнения процедур с помощью кода:

Excel.DisplayAlerts = 0; 
Excel.Quit();
Excel.DisplayAlerts = 1;

Универсальную загрузку из excel в 1C можно бесплатно скачать тут.

Обратите внимание, эта обработка написана в режиме «обычного приложения 1С».

Если у вас всё же возникли проблемы с загрузкой, вы можете обратиться за помощью к опытному программисту 1C.

Видеоурок по загрузке товаров в 1С из файлов Excel:

P.S. Наша компания предоставляет услуги по настройке, доработке и комплексному внедрению 1С. Закажите бесплатный расчет стоимости вашей задачи на странице Услуги 1С или по телефону +7 (499) 350 29 00.

Остались вопросы?

СПРОСИТЕ в комментариях!

Комментариев: 29 на “Инструкция по загрузке из Excel в 1C для программиста
  1. Ссылка на файл обработки не работает, перезагрузите, пожалуйста!

    Ответить

    • Вроде работает.
      Попробуйте правой кнопкой — Сохранить как…

      Ответить

    • Поместил в zip архив.
      Теперь любой браузер должен понять что по ссылке нужно скачать файл 🙂

      Ответить

  2. Добрый день!
    При открытии обработки, открывается пустая страница.

    Ответить

    • Здравствуйте!

      Обработка разработана на обычных формах, а у вас (как я понимаю) управляемое приложение.

      Ответить

  3. Файл выбирается, происходит обработка, но вот в таблице он не отображается

    Ответить

    • А заголовки в файле есть? Какие они? Лист в эксель один?

      Ответить

  4. Большое спасибо!!! Очень помогло

    Ответить

  5. Данная обработка не работает с Бухгалтерией предприятия 8.3. Вываливается пустое окно. Видимо это от 8.2

    Ответить

    • Запусти в режиме Управляемая прикладная программа

      Ответить

  6. Подскажите, а как загружать в 1с 8.3 из екселя формата xlsb это двоичные данные.

    Ответить

    • К сожалению, с такими файлами не имел дело. А сохранить в обычный файл невозможно?

      Ответить

  7. Здравствуйте, Кирилл. Такой вопрос. С загрузкой файла разобрался, но не могу загрузить файл большого объема — порядка 1,5 тысяч строк в экселе. Как исправить не знаю. Подскажите

    Ответить

    • Добрый день, Дмитрий.

      А какую ошибку выдает?
      Я на практике загружал и 50 и 100 тысяч товаров — всё было отлично.

      Ответить

  8. Спасибо. Полезная инфа. Непонятно как работать с методами и свойствами объекта Excel(который вы создавали в коде). Я говорю о таких методах, как, например, Excel.WorkBooks.Open(ИмяФайла); Где взять описание этого метода Open() объекта Excel.WorkBooks. И какой тип будет иметь объект Excel.WorkBooks?

    Ответить

  9. Здравствуйте. Есть проблема, при нажатии на кнопку «Выбрать» выдает ошибку, не понимаю как фиксить…

    »
    {Форма.Форма.Форма(11)}: Ошибка при вызове метода контекста (Выбрать)
    Если ДиалогВыбора.Выбрать() Тогда
    по причине:
    Использование синхронных методов на клиенте запрещено!
    «

    Ответить

    • Добрый день!

      Код в посте приведен для старого режима работы 1С.
      Ваша конфигурация работает в «асинхронном режиме».

      Выхода для вас два:

      1. Переписать код вызова диалога с помощью «оповещений».

      2. Включить в свойствах корня конфигурации поддержку синхронных вызовов.

      Более подробно:
      http://programmist1s.ru/ispolzovanie-modalnyih-okon-v-dannom-rezhime-zapreshheno/

      Ответить

  10. а Ексель закрывать не надо в конце?

    Ответить

    • Конечно нужно. Спасибо за замечание)
      Добавил в статью)

      Ответить

  11. Можете эту обработку переделать для управ.форм

    Ответить

    • Да тоже, был бы очень признателен если переделали обработку для управляемых форм.

      Ответить

    • Обработка написана скорее для программистов, я думаю у них не составит труда переписать её 🙂

      А для пользователей я бы рекомендовал универсальную загрузку от 1с:

      http://programmist1s.ru/zagruzka-nomenklaturyi-v-1s-8-3-iz-excel-ili-dbf/

      Ответить

  12. Здравствуйте. Вы рассматриваете загрузку из Excel в 1C, а есть ли пример кода или готовая обработка, которая бы наоборот выгружала данные из 1С в Excel. Заранее спасибо за ответ)))

    Ответить

    • Здравствуйте, Нара.

      Там очень много вариантов выгрузки из 1С типовыми способами. Вот здесь некоторые расписаны — http://programmist1s.ru/vyigruzka-dannyih-iz-1s/

      Ответить

      • А можно ли где-нибудь скачать готовую обработку? Я пока новичок и не очень хорошо понимаю как это делать самостоятельно)

        Ответить

        • Готовых нет, нужно понимать какие данные грузить, в зависимости от этого уже подбирать инструмент

          Ответить

  13. Если ДиалогВыбора.Выбрать() Тогда
    ИмяФайла = ДиалогВыбора.ПолноеИмяФайла;
    Иначе
    возврат;
    КонецЕсли;

    Ответить

  14. так будет правильней…

    Ответить

Добавить комментарий:

Ваш e-mail не будет опубликован. Обязательные поля помечены *


*

Получите 267 видео уроков по 1С бесплатно:

Гарантируем – никакого спама!