Закажите бесплатный расчет стоимости вашей задачи по 1С!
Перезвоним за 10 минут!

Установка подсистемы 1С БСП — Оценка производительности

Ниже мы рассмотрим процесс внедрения и настройки подсистемы 1С 8.2 Библиотека стандартных подсистем — Оценка производительности.

Подсистема предназначена для объективной оценки интегральной производительности системы по методике APDEX. С помощью неё, например, можно узнать сколько занимает время проведения определенного документа и в дальнейшем получить статистику за время.

Рассмотрим подробно процесс установки данной подсистемы.

Установка подсистемы БСП — Оценка производительности

Сравниваем нашу конфигурацию с последней конфигурацией Библиотека стандартных подсистем. В окне сравнения-объединения необходимо снять все галки. После этого выбираем меню «Действия – Отметить по подсистемам файла». Галку ставим только на подсистему ОценкаПроизводительности (подчиненные оставляем включать, родительские – не включать). Нажимаем Установить. В окне сравнения-объединения Общие – Подсистемы – Стандартные Подсистемы- ОценкаПроизводительности –Поставить галку. После всех этих действий нажмите Выполнить объединение. После объединения, в перечисление Ключевые операции добавить предопределенные элементы(напр. ПроведениеДокумента)

Получите 267 видеоуроков по 1С бесплатно:

Следующий шаг — вставка кода для замера ключевых операций. Рассмотрим этот процесс на примере обработчика проведения. Когда документ проводится при нажатии кнопки «ОК» и нам необходимо выполнить замер времени проведения:

Если «ОК» стандартная кнопка.

Для обычных форм:

Открыть форму на редактирование, в контекстном меню кнопки выбирать пункт «Удалить», создать новую кнопку с таким же именем и разместить ее на форме.

Для управляемых форм:

Открыть форму на редактирование, в свойствах формы(свойство «Состав команд») отключить отображение команды «ОК», в редакторе форм создать новую команду с именем «ОК», расположить ее на форме, при необходимости установить свойство «КнопкаПоУмолчанию» в значение «Истина».
Обработчик кнопки (команды) может выглядеть следующим образом:

&НаКлиенте
Процедура КомандаОК(Команда)

#Если ТолстыйКлиентОбычноеПриложение Тогда
КлючеваяОперация = Перечисления.КлючевыеОперации.ПроведениеДокумента;
#Иначе
КлючеваяОперация = ПредопределенноеЗначение(«Перечисление.КлючевыеОперации.ПроведениеДокумента»);
#КонецЕсли
ОценкаПроизводительностиКлиентСервер.НачатьЗамерВремени(КлючеваяОперация);

Попытка
#Если ТолстыйКлиентОбычноеПриложение Тогда
ЗаписатьВФорме(РежимЗаписиДокумента.Проведение);
#Иначе
ПараметрыЗаписи = Новый Структура(«РежимЗаписи»);
ПараметрыЗаписи.РежимЗаписи = РежимЗаписиДокумента.Проведение;
ЭтаФорма.Записать(ПараметрыЗаписи);
#КонецЕсли
Исключение
//Обработка неудачного проведения документа
//Впишите код для обработки неудачного проведения документа —>
//…
КонецПопытки;
ЭтаФорма.Закрыть();
КонецПроцедуры;

«ОК» не стандартная кнопка.

Найти обработчик нажатия кнопки (команды) и изменить его следующим образом:

&НаКлиенте
Процедура КомандаОК(Команда)

#Если ТолстыйКлиентОбычноеПриложение Тогда
КлючеваяОперация = Перечисления.КлючевыеОперации.ПроведениеДокумента;
#Иначе
КлючеваяОперация = ПредопределенноеЗначение(«Перечисление.КлючевыеОперации.ПроведениеДокумента»);
#КонецЕсли
ОценкаПроизводительностиКлиентСервер.НачатьЗамерВремени(КлючеваяОперация);

//……
//Код написанный в обработчике
//……

КонецПроцедуры

После этих действий необходимо константу ВыполнятьЗамерыПроизводительности установить в Истину, для чего сделать обработку, с одной кнопкой и одной процедурой – обработчиком нажатия:

Процедура КнопкаВыполнитьНажатие(Кнопка)
Константы.ВыполнятьЗамерыПроизводительности.Установить(Истина);
КонецПроцедуры

Для анализа значений APDEX, нужно использовать обработку «Оценка производительности» (Операции – Обработки…). Чтобы ее использовать, нужно задать период, шаг периода и целевое время, в списке оставить только свою ключевую операцию и «общую производительность системы» и нажать «Обновить показатели производительности»

P.S. Наша компания предоставляет услуги по настройке, доработке и комплексному внедрению 1С. Закажите бесплатный расчет стоимости вашей задачи на странице Услуги 1С или по телефону +7 (499) 350 29 00.

Остались вопросы?

СПРОСИТЕ в комментариях!

Добавить комментарий:

Ваш e-mail не будет опубликован. Обязательные поля помечены *


*