Закажите бесплатный расчет стоимости вашей задачи по 1С!
Перезвоним за 10 минут!

Информационная карточка клиента УТ 11

Компания занимается торговлей металлопрокатом. Внести в типовую конфигурацию отчет «Информационная карточка клиента». Под клиентом понимается элемент справочника «Партнеры».

Внешний вид карточки:

решение задач специалист консультант ЗУП

 

Данная форма заполняется данными за последний год (не календарный, а интервал — год).

Если отгрузок какого-то наименования было более одной, то информация должна попадать в пункт потребность «постоянная», где указывается средний интервал между отгрузками. Средний интервал определяется как количество рабочих дней в году (по основному графику работы компании), разделенное на количество документов по данному товару.

Если отгрузка была только одна — в графу разовая должна попасть дата отгрузки.

Отчет необходимо разместить в форме «Отчеты по продажам».

Остались вопросы?

СПРОСИТЕ в комментариях!

Один комментарий на “Информационная карточка клиента УТ 11
  1. Все бы хорошо но вот группа номенклатуры в отчетах на СКД отображается в каждой строчке, а в задании она общая;
    Так вот сообразил как сделать так чтобы все было 1 в 1, вот код модуля отчета
    Перем ТекДанные;
    Перем ПерваяСтрока;

    Процедура ПриКомпоновкеРезультата(ДокументРезультат, ДанныеРасшифровки, СтандартнаяОбработка)
    //Вывод программно
    СтандартнаяОбработка = Ложь;

    КомпоновщикМакета = Новый КомпоновщикМакетаКомпоновкиДанных;
    Макет = КомпоновщикМакета.Выполнить(СхемаКомпоновкиДанных, КомпоновщикНастроек.ПолучитьНастройки(), ДанныеРасшифровки);

    ПроцессорКомпоновки = Новый ПроцессорКомпоновкиДанных;
    ПроцессорКомпоновки.Инициализировать(Макет, , ДанныеРасшифровки);

    ПроцессорВывода = Новый ПроцессорВыводаРезультатаКомпоновкиДанныхВТабличныйДокумент;
    ПроцессорВывода.УстановитьДокумент(ДокументРезультат);
    ПроцессорВывода.Вывести(ПроцессорКомпоновки);

    //Корректировка документа результата
    КолКолонок = ДокументРезультат.ШиринаТаблицы;
    КолСтрок = ДокументРезультат.ВысотаТаблицы;

    Для Кол = 1 По КолКолонок Цикл

    Для Стр = 1 По КолСтрок Цикл

    ТекЯчейка = ДокументРезультат.Область(Стр, Кол);
    Если ТекЯчейка.Расшифровка Неопределено Тогда

    ПоляРасшифровки = ДанныеРасшифровки.Элементы[ТекЯчейка.Расшифровка].ПолучитьПоля();

    Если ПоляРасшифровки.Количество() > 0 Тогда

    ТекПолеРасшифровки = ПоляРасшифровки[0].Значение;

    Если ТипЗнч(ТекПолеРасшифровки) = Тип(«СправочникСсылка.Номенклатура»)
    И ЗначениеЗаполнено(ТекПолеРасшифровки) Тогда

    Если ТекДанные = ТекПолеРасшифровки Тогда
    ОбщаяОбласть = ДокументРезультат.Область(ПерваяСтрока, Кол, Стр, Кол);
    ОбщаяОбласть.Объединить();
    Иначе
    ПерваяСтрока = Стр;
    КонецЕсли;

    ТекДанные = ТекПолеРасшифровки;

    КонецЕсли;
    КонецЕсли;
    КонецЕсли;
    КонецЦикла;
    КонецЦикла;

    КонецПроцедуры

    Ответить

Добавить комментарий:

Ваш e-mail не будет опубликован. Обязательные поля помечены *


*