Закажите бесплатный расчет стоимости вашей задачи по 1С!
Перезвоним за 10 минут!

Установка ссылки нового элемента в регистр сведений 1С 8.3

Бывает ситуации, когда при записи элемента справочника 1С 8.3 или 8.2 (или другой объектной сущности) необходимо выполнить запись какого либо набора регистра сведений, где в измерении(или ресурсе) необходимо установить ссылку на записываемый объект. Для решение данной задачи необходимо использовать метод «УстановитьСсылкуНового()». Рассмотрим его использование подробнее.

ссылка нового

Установка ссылки нового объекта в регистр сведений 1С

Рассмотрим установку ссылки нового элемента программно на примере процедуре записи контактной информации в соответствующий регистр сведений:

Процедура ПриЗаписи(Отказ)

Если ЭтоНовый() Тогда

СсылкаНового = ЭтотОбъект.ПолучитьСсылкуНового();

Если НЕ ЗначениеЗаполнено(СсылкаНового) Тогда

СсылкаНового = Справочники.Контрагенты.ПолучитьСсылку();

КонецЕсли;

МенеджерЗаписи = РегистрыСведений.КонтактнаяИнформация.СоздатьМенеджерЗаписи();

МенеджерЗаписи.Партнер = СсылкаНового;

МенеджерЗаписи.Представление = Адрес;

ЭтотОбъект.УстановитьСсылкуНового(СсылкаНового);

КонецЕсли;

КонецПроцедуры

Остались вопросы?

СПРОСИТЕ в комментариях!

Добавить комментарий:

Ваш e-mail не будет опубликован. Обязательные поля помечены *


*