Закажите бесплатный расчет стоимости вашей задачи по 1С!
Перезвоним за 10 минут!

Установка ссылки нового элемента в регистр сведений 1С 8.3

Бывает ситуации, когда при записи элемента справочника 1С 8.3 или 8.2 (или другой объектной сущности) необходимо выполнить запись какого-либо набора регистра сведений, где в измерении (или ресурсе) необходимо установить ссылку на записываемый объект. Для решения данной задачи необходимо использовать метод «УстановитьСсылкуНового()». Рассмотрим его использование подробнее.

ссылка нового

Установка ссылки нового объекта в регистр сведений 1С

Рассмотрим установку ссылки нового элемента программно на примере процедуре записи контактной информации в соответствующий регистр сведений:

Процедура ПриЗаписи(Отказ)

Если ЭтоНовый() Тогда

СсылкаНового = ЭтотОбъект.ПолучитьСсылкуНового();

Если НЕ ЗначениеЗаполнено(СсылкаНового) Тогда

СсылкаНового = Справочники.Контрагенты.ПолучитьСсылку();

КонецЕсли;

МенеджерЗаписи = РегистрыСведений.КонтактнаяИнформация.СоздатьМенеджерЗаписи();

МенеджерЗаписи.Партнер = СсылкаНового;

МенеджерЗаписи.Представление = Адрес;

ЭтотОбъект.УстановитьСсылкуНового(СсылкаНового);

КонецЕсли;

КонецПроцедуры

Остались вопросы?

СПРОСИТЕ в комментариях!

Комментариев: 4 на “Установка ссылки нового элемента в регистр сведений 1С 8.3
  1. вы это хоть сами проверяли?

    Ответить

  2. В ПриЗаписи() не работает никогда:
    ЭтоНовый() Возвращаемое значение: Истина — изменяется еще ни разу не записанный элемент; Ложь — элемент уже записан.
    Работает только в ПередЗаписью().
    Правильный вариант (http://forum-1c.ru/index.php?topic=32864.0):
    Процедура ПриЗаписи(Отказ)
    Если ЭтотОбъект.ДополнительныеСвойства.Новый Тогда
    //Ваш код
    КонецЕсли;
    КонецПроцедуры

    Процедура ПередЗаписью(Отказ)
    ЭтотОбъект.ДополнительныеСвойства.Вставить(«Новый», ЭтоНовый());
    КонецПроцедуры

    Ответить

    • Не то, чтобы правильный, но работающий…

      Ответить

Добавить комментарий:

Ваш e-mail не будет опубликован.