Закажите бесплатный расчет стоимости вашей задачи по 1С!
Перезвоним за 10 минут!

Пример создания диаграммы Ганта в 1С 8.2 (8.3)

Диаграмма Ганта – очень важный объект в системе 1С Предприятие 8.3. Рассмотрим создание и вывод в интерфейс данного объекта.


созадние формы диаграммы ГАНТА

Создание и настройка диаграммы Ганта в 1С

Рассмотрим создание и настройку отчета «диаграмма Ганта» на примере отчета по кадровой информации.

Создадим отчет, на форме необходимо разместить реквизит формы с типом ДиаграммаГанта и в нашем примере в качестве настройки реквизит формы с типом Стандартный период. Также создадим на форме команду – Сформировать:

В обработчик команды Сформировать занесем следующий программный код:

Получите 267 видеоуроков по 1С бесплатно:

НаКлиенте

Процедура Сформировать(Команда)

СформироватьНаСервере();

КонецПроцедуры

Процедура СформироватьНаСервере()

ДГ.Очистить();

ДГ.Обновление = Ложь;

Запрос = Новый Запрос("ВЫБРАТЬ

|             ОсновныеНачисленияФактическийПериодДействия.Сотрудник,

|             ОсновныеНачисленияФактическийПериодДействия.ВидРасчета,

|             ОсновныеНачисленияФактическийПериодДействия.ПериодДействияНачало КАК Начало,

|             ОсновныеНачисленияФактическийПериодДействия.ПериодДействияКонец КАК Конец

|ИЗ

|             РегистрРасчета.ОсновныеНачисления.ФактическийПериодДействия КАК ОсновныеНачисленияФактическийПериодДействия

|ГДЕ

|             ОсновныеНачисленияФактическийПериодДействия.ПериодДействия МЕЖДУ &ДатаНачала И &ДатаОкончания");

Запрос.УстановитьПараметр("ДатаНачала", Период.ДатаНачала);

Запрос.УстановитьПараметр("ДатаОкончания", Период.ДатаОкончания);

Выборка = Запрос.Выполнить().Выбрать();

Пока Выборка.Следующий() Цикл

Точка = ДГ.УстановитьТочку(Выборка.Сотрудник);

Серия = ДГ.УстановитьСерию(Выборка.ВидРасчета);

Значение = ДГ.ПолучитьЗначение(Точка, Серия);

Интервал = Значение.Добавить();

Интервал.Начало = Выборка.Начало;

Интервал.Конец = Выборка.Конец;

КонецЦикла;

ДГ.Обновление = Истина;

КонецПроцедуры

В результате получится вот такой вот красивый отчет Диаграмма Ганта:

Результат работы диаграммы Ганта

Читайте также другие статьи по 1С:

Если Вы начинаете изучать 1С программирование, рекомендуем наш бесплатный курс (не забудьте подписаться на YouTube — регулярно выходят новые видео):

P.S. Наша компания предоставляет услуги по настройке, доработке и комплексному внедрению 1С. Закажите бесплатный расчет стоимости вашей задачи на странице Услуги 1С или по телефону +7 (499) 350 29 00.

Остались вопросы?

СПРОСИТЕ в комментариях!

Добавить комментарий: