Закажите бесплатный расчет стоимости вашей задачи по 1С!
Перезвоним за 10 минут!

Переменная не определена (ПоступлениеТоваров) 1С 8.2

При формировании движения в 1С 8.2 на увеличение, при добавлении кода процедуры обработки, выдает ошибку: {РегистрНакопления.ОстаткиТоваровНаСкладе.МодульНабораЗаписей (3,21)}: Переменная не определена (ПоступлениеТоваров)
Скажите пожалуйста в чем ошибка???
Код прилагается:

Процедура ОбработкаЗаполнения(ДанныеЗаполнения, СтандартнаяОбработка)
//{{__КОНСТРУКТОР_ВВОД_НА_ОСНОВАНИИ
// Данный фрагмент построен конструктором.
// При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!
Если ТипЗнч(ДанныеЗаполнения) = Тип(«ДокументСсылка.ПоступлениеТоваров») Тогда
// Заполнение шапки
Комментарий = ДанныеЗаполнения.Комментарий;
Контрагент = ДанныеЗаполнения.Контрагент;
Ответственный = ДанныеЗаполнения.Ответственный;
Склад = ДанныеЗаполнения.Склад;
Для Каждого ТекСтрокаТовары Из ДанныеЗаполнения.Товары Цикл
НоваяСтрока = Товары.Добавить();
НоваяСтрока.Количество = ТекСтрокаТовары.Количество;
НоваяСтрока.Номенклатура = ТекСтрокаТовары.Номенклатура;
НоваяСтрока.Сумма = ТекСтрокаТовары.Сумма;
НоваяСтрока.Цена = ТекСтрокаТовары.Цена;
КонецЦикла;
КонецЕсли;
//}}__КОНСТРУКТОР_ВВОД_НА_ОСНОВАНИИ
КонецПроцедуры

Процедура ОбработкаПроведения(Отказ, РежимПроведения)
Движения.ОстаткиТоваровНаСкладе.Записывать = Истина;
Для каждого Стр Из Товары Цикл
Запись = Движения.ОстаткиТоваровНаСкладе.Добавить();
Запись.Период = Дата;
Запись.Номенклатура = Стр.Номенклатура;
Запись.Склад = Склад;
Запись.Количество = Стр.Количество;
Запись.ВидДвижения = ВидДвиженияНакопления.Приход;

КонецЦикла;

КонецПроцедуры

Остались вопросы?

Задайте ВОПРОС на нашем форуме 1С! ››

СПРОСИТЕ в комментариях!

Комментариев: 12 на “Переменная не определена (ПоступлениеТоваров) 1С 8.2
  1. Если внимательно прочитать ошибку, можно увидить что ошибка не в этом модуле.

    А в РегистрНакопления.ОстаткиТоваровНаСкладе.МодульНабораЗаписей (3,21)

    Ответить

  2. Дописал период к регистру и все равно ошибка, что делать?

    Процедура ОбработкаПроведения(Отказ, РежимПроведения)

    Для каждого Стр Из ПоступлениеТоваров Цикл
    Запись = Движения.ОстаткиТоваровНаСкладе.Добавить();
    Запись.Период = Дата;
    Запись.Номенклатура = Стр.Номенклатура;
    Запись.Склад = Склад;
    Запись.Количество = Стр.Количество;
    Запись.ВидДвижения = ВидДвиженияНакопления.Приход;

    КонецЦикла;
    Движения.ОстаткиТоваровНаСкладе.Записывать = Истина
    КонецПроцедуры

    Ответить

    • Еще раз повторяю:
      Ошибка в модуле набора записей регистра ОстаткиТоваровНаСкладе

      Ответить

  3. что примерно нужно изменить?

    Ответить

    • Нужно исправить ошибку в модуле набора записей регистра ОстаткиТоваровНаСкладе 🙂

      Заходите в этот модуль и исправляете.

      Вы мне скидываете обработку проведения документа, она тут не причём.

      Ответить

  4. Там кода нету вообще)) исправлять, не чего, может быть что то конкретно дописать мне?:)

    Ответить

    • Не верю что кода нет)))

      Правой кнопкой на регистре накопления в древе метаданных. Там выбираете «модуль набора записей»)

      Ответить

    • Нажмите когда ошибка появится кнопку «конфигуратор» и программа вас закинет на строчку кода.

      Кнопка появляется только в толстом клиенте.

      Ответить

  5. там только процедура обработки проведения, которую чуть выше я вам скидывал)

    Ответить

    • Обработка проведения находится в модуле документа.

      В модулях регистров обработки проведения не бывает.

      Ответить

  6. убрал код, спасибо заработало=)

    Ответить

Добавить комментарий:

Ваш e-mail не будет опубликован. Обязательные поля помечены *


*