Закажите бесплатный расчет стоимости вашей задачи по 1С!
Перезвоним за 10 минут!

Как пометить на удаление все документы в 1С 8.3

Очень часто бывает нужно очистить базу от всех существующих документов. Чаще всего такое бывает когда предприятие меняет юридическое лицо. Справочники при этом нужно оставить, а документы удалить. Рассмотрим как с помощью простой обработки можно пометить на удаление все документы в 1С 8.3.

Внимание! Перед запуском обработки обязательно сделайте резервную копию базы данных 1С. Данные изменения необратимы.

Удаление всех документов 1С для пользователей

После того, как копия сделана, необходимо скачать специальную обработку — Удаление всех документов в 1С 8.3. Она универсальна и подойдет для любых конфигураций 1С на базе 8.2 и 8.3.

Для открытия обработки выберите пункт главного меню «Файл — Открыть»:

открытие обработки

Где нужно выбрать путь к скаченной обработки на вашем жестком диске.

После открытия обработка выглядит очень просто:

кнопка для удаления

Получите 267 видеоуроков по 1С бесплатно:

Что бы запустить процесс, необходимо нажать на единственную кнопку. Для больших баз время удаление может составить более 10 часов. Для примера — демонстрационная база 1С Бухгалтерия обрабатывается около 5 минут на компьютере средней мощности. После окончания работы, документы, которые обработка не смогла пометить на удаление, отобразятся в поле сообщений с указанием причины.

Когда выполнение завершено, можно убедится что документы помечены на удаление зайдя в любой журнал документов:

готово!

После этого, можно запускать Удаление помеченных объектов.

Для программистов

Обработка работает очень просто: она перебирает все виды документов, а затем обходит все документы конкретного типа.

Исходный код:

Для Каждого ТекМД из Метаданные.Документы Цикл
		
	Выборка = Документы[ТекМД.Имя].Выбрать();
		
	Пока Выборка.Следующий() Цикл
			
		ТекОб = Выборка.ПолучитьОбъект();
			
		Если ТекОб.ПометкаУдаления Тогда 
			Продолжить;
		КонецЕсли;
			
		Попытка
			ТекОб.УстановитьПометкуУдаления(Истина);
		Исключение
			Сообщить("Документ " + ТекОб + " не удалось пометить на удаление, по причине " + ОписаниеОшибки());			
		КонецПопытки;
			
	КонецЦикла;
		
		
КонецЦикла;

P.S. Наша компания предоставляет услуги по настройке, доработке и комплексному внедрению 1С. Закажите бесплатный расчет стоимости вашей задачи на странице Услуги 1С или по телефону +7 (499) 350 29 00.

Остались вопросы?

Задайте ВОПРОС на нашем форуме 1С! ››

СПРОСИТЕ в комментариях!

Добавить комментарий:

Ваш e-mail не будет опубликован. Обязательные поля помечены *


*