Закажите бесплатный расчет стоимости вашей задачи по 1С!
Перезвоним за 10 минут!

ЭтоНовый в управляемых формах 1С (8.2 и 8.3)

К сожалению, в управляемых формах нет аналога метода ЭтоНовый() для получения информации о том, есть ли ссылка у этого объекта, записан ли объект в информационную базу. В управляемых формах этот метод сделан немного иначе, рассмотрим, как получить информацию о том, новый ли объект в режиме управляемого приложения.

этоновый

Аналог ЭтоНовый() в управляемом приложении

Чтобы выяснить новый объект или нет, необходимо использовать конструкцию вида:

Параметры.Ключ.Пустая();

Если объект записан в базу данных, он содержит ссылку на объект — Ключ. Если ключ пустой- объект новый.

Например:

Если НЕ Параметры.Ключ.Пустая() Тогда
Возврат Истина;
КонецЕсли;

Другие статьи по 1С:

Если Вы начинаете изучать 1С программирование, рекомендуем наш бесплатный курс (не забудьте подписаться на YouTube — регулярно выходят новые видео):

P.S. Наша компания предоставляет услуги по настройке, доработке и комплексному внедрению 1С. Закажите бесплатный расчет стоимости вашей задачи на странице Услуги 1С или по телефону +7 (499) 350 29 00.

Остались вопросы?

СПРОСИТЕ в комментариях!

Комментариев: 7 на “ЭтоНовый в управляемых формах 1С (8.2 и 8.3)
  1. можно так

    ДокументОбъект = РеквизитФормыВЗначение(«Объект»);
    Если ДокументОбъект.ЭтоНовый() Тогда
    //
    КонецЕсли;

    Ответить

  2. не проще ли
    Если Не ЗначениеЗаполнено(Объект.Ссылка) Тогда
    //
    КонецЕсли;

    Ответить

    • Не отрабатывает лично у меня.

      Я рекомендую так:

      Если НЕ Объект.Ссылка.Пустая() Тогда
      //
      КонецЕсли;

      Ответить

      • Если Объект.Ссылка.Пустая() Тогда
        //
        КонецЕсли;

        Ответить

  3. А чем не нравится
    Если ЗначениеЗаполнено(Объект.Ссылка) Тогда
    /////
    КонцеЕсли;

    Ответить

Добавить комментарий: